Jornaya SFTP Server Issue
Incident Report for Jornaya
Resolved
We have identified the issue with the Jornaya SFTP Server and the server is back online at this time.
Posted 8 months ago. Jan 30, 2019 - 10:58 EST
Investigating
We are currently investigating an issue impacting the Jornaya SFTP Server.
Posted 8 months ago. Jan 30, 2019 - 10:52 EST