Performance Degradation Generating New LeadiDs
Incident Report for Jornaya
Resolved
The performance issue affecting the generation of new LeadiDs has been identified and resolved.
Posted over 1 year ago. Feb 28, 2018 - 06:58 EST
Investigating
We are currently investigating a performance issue affecting the generation of new LeadiDs.
Posted over 1 year ago. Feb 28, 2018 - 06:39 EST